Harley Davidson Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
Hello I'm new to this forum and just finished a bunch of upgrades on my 2008 roadglide. After putting everything back together the rear blinkers and brake lights work perfectly, but the front blinkers are on but don't blink.
One looks brighter then the other. Sometimes the back will blink really fast and sometimes it's normal, but the front don't ever blink.

Before powdercoat I took the entire blinker housings apart, was thinking something wasnt connected right inside but the back ones are good.
Any and all help is greatly appreciated. Thank you for your time and reading this post.
 

·
Registered
Joined
·
3,173 Posts
Hello I'm new to this forum and just finished a bunch of upgrades on my 2008 roadglide. After putting everything back together the rear blinkers and brake lights work perfectly, but the front blinkers are on but don't blink.
One looks brighter then the other. Sometimes the back will blink really fast and sometimes it's normal, but the front don't ever blink.

Before powdercoat I took the entire blinker housings apart, was thinking something wasnt connected right inside but the back ones are good.
Any and all help is greatly appreciated. Thank you for your time and reading this post.
Inspect the bulb filaments - the dimmer one may be giving up causing a resistance on the circuit.

Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
142 Posts
It's a bad ground on the dim light . Maybe between the bulb and socket or between the socket and the mount. Use a screwdriver and place it between the bulb and base or base and lamp itself. If the bulb gets brighter and flashes thats where your problem is. Good Luck!
 

·
Registered
Joined
·
1,317 Posts
I put new turn signals on front and rear and had the same problem. Fixed bad ground wire from the front left and it works great.
 

·
Registered
Joined
·
595 Posts
I had the 2 wires that go into the plastic divider backwards (plastic cap that sits ontop of spring). Have you flipped wire locations yet? (They have to match front and back left and right)(straight slot and a diaganol slot- same color in respective slot)

Sent from Motorcycle.com Free App
 

·
Registered
Joined
·
45 Posts
Discussion Starter #7
It turned out to be the two wires which are blue and purple on the bottom of the bulb were reversed on the bulb. Thank you all who had input.
 
1 - 7 of 7 Posts
Top