Harley Davidson Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
bike will run great then just shut off has spark,new fuel pump,new crank sensor,cranks over great noticed fuel pump not coming on replaced pump relay,this is a m.m system so no fuel pressure switch,Question will bike crank over with spark if bank angle switch is bad? or any other ideas
 

·
Registered
Joined
·
511 Posts
I had same issue a few times with my '02. Fixed itself so I never did figure out what was causing the problem.
Does it start right back up?

Sent from my coal fired bag phone using Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
i did the reset on/off etc.started right back up,when it wont the fuel pump doesnt come on,there is no fuel pump pressure switch on a 2000 the excess fuel just returns to tank.and it seems to take a while for pump to come on after you turn switch on
 

·
Retired citizen
Joined
·
22,542 Posts
bike will run great then just shut off has spark,new fuel pump,new crank sensor,cranks over great noticed fuel pump not coming on replaced pump relay,this is a m.m system so no fuel pressure switch,Question will bike crank over with spark if bank angle switch is bad? or any other ideas
No the engine won't turn over if the BAS is tripped.
None of the H-D fuel delivery systems have sensors that'll trigger codes, none that I'm aware of anyways.
The fuel pump should only turn on for 3 seconds when the ignition is turned on. After the engine starts the pump should be running.
The fuel pressure regulator is mounted on the M&M throttle body not in the tank like the Delphi systems.
I'm wondering if the OP replaced the in tank fuel filter when he replaced the fuel pump ?
Also did the OP inspect the CMP sensor ? Remove that and look for signs of scraping in the slot.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
so i replaced the filter when i replaced the fuel pump,what is cmp sensor? it will run great sitting in garage,but then when you go for a ride it could be 100 feet or 100 miles the fuel pump just shuts off replaced crank sensor,fuel pump relay,fuel pump and filter,what is op,thanks
 

·
Barney Fife - Poser
Joined
·
893 Posts
so i replaced the filter when i replaced the fuel pump,what is cmp sensor? it will run great sitting in garage,but then when you go for a ride it could be 100 feet or 100 miles the fuel pump just shuts off replaced crank sensor,fuel pump relay,fuel pump and filter,what is op,thanks
CMP = cam position sensor

OP = original poster

How are you sure that the fuel pump is shutting off?

What made you decide to replace the crank sensor if you didn't get any codes?

Did you actually check for stored codes or just assume that there aren't any because the engine light is not on?

If the fuel pump is really shutting off then I would be thinking there is a broken wire or loose or corroded connection somewhere. Could it be that the injectors are cutting out? The wires that power the injectors are notorious for getting chaffed or broken under the tank and causing intermittent run problems.

If the engine is randomly shutting down and/or stuttering then it could be a failing engine temp sensor.

You need to actively look for stored trouble codes. Do you have a factory service manual?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
crank sensor because before this problem it threw codes,fuel pump because you can hear it not coming on before you do reset,after it shuts down,at first i almost thought it was ing.switch because turning it of and on a few times the the pump came on,that being said thats what led me to think maybe bank switch because of reset,but it will crank over but no fuel pump until reset
 

·
Barney Fife - Poser
Joined
·
893 Posts
crank sensor because before this problem it threw codes,fuel pump because you can hear it not coming on before you do reset,after it shuts down,at first i almost thought it was ing.switch because turning it of and on a few times the the pump came on,that being said thats what led me to think maybe bank switch because of reset,but it will crank over but no fuel pump until reset
The fuel pump runs to pressurize the fuel line. If it is pressurized then the pump doesn't need to run.

When you say "no fuel" what does that mean? Plugs are dry? No fuel into intake? You have verified spark? How do you know that the injectors are firing? Have you tried squirting some fuel or starter fluid into the intake to get it started? That could confirm a fuel delivery problem but that could still be the injectors.

Do you have a factory manual? That would have the troubleshooting chart you really need to figure out what the problem is. Every time you mess with something else you create another unknown.
 
1 - 10 of 10 Posts
Top