Harley Davidson Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
329 Posts
Discussion Starter · #1 ·
Hey all,

I had installed the blacked out latches p/n 53000130 a few years back and they just will not stay latched. I always keep the lid locked. Probably a good thing but they latches dropping down just sucks. There is no lip to keep them attached. Probably a design mistake. I have seen the new type that mounts above the lip. Has anyone installed these in a black or chrome and do they work? I have attached screen shots of both. The new design is p/n 53000253. Thanks for any input for these latches.
 

Attachments

·
Retired citizen
Joined
·
24,536 Posts
It sounds like you're missing the top pieces for the latches. The pieces that rivet to the lid.
 

·
Registered
Joined
·
329 Posts
Discussion Starter · #3 ·
No they are there. Its just those pieces have no lip on leading edge. I do lots of work on my own bikes since I am a tech on machines at my work by trade and this was an easy install, they just never latched very tight.
 

·
Retired citizen
Joined
·
24,536 Posts
Those are the two pieces I was referring to. I just installed a new pair of chrome latch assys. on a '03 Ultra and they latch perfect, nice and tight.
I also re-riveted the hinges because the lid wasn't lining up very well.
Was the black latch kit a H-D kit ?
 

·
Registered
Joined
·
329 Posts
Discussion Starter · #8 ·
Just an update, bought another set same type and just replaced the upper in the photo above and they are tight on latch. Comparing new and old the old has the pins internal worn out. Maybe like another post if you dont lock the top lid it may cause this. For 35 bucks work a try over the reviews of the premium 99 buck latches and how sorry they can be plus I dont have to drill the lid out.
 
1 - 8 of 8 Posts
Top