Harley Davidson Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi Everyone...my check engine light keeps coming on and I loose all throttle control. It just goe to idle. Its been at 3 different Harley dealers and they all change parts and reset codes but the problem keeps accuring. The throttle cartridge has been changed twice and the lat dealer said it was the system relay, so he changed it and it ran fine for about 3 months. Now it happened again so I changed it but but the light keeps coming on. Any suggetion? oh its on a 2009 Ultra Classic...
 

·
Village Idiot
Joined
·
2,300 Posts
You should do two things. First go to the new members section and post an introduction ( its the polite thing to do) and second, search for the sticky on how to pull up the codes and cross reference them to see what the code means, that way you know first hand what the system is saying is going on.


Sent from Motorcycle.com App
 

·
Just Ride
Joined
·
3,035 Posts
A brother had the same problem, ended up being the stator. He would have to turn his bike off &on about 5 times to get it to run right.
Dealer replaced under warranty been good since.
Sent from Motorcycle.com Free App
 

·
Killer of Souls
Joined
·
10,862 Posts
First Welcome...
Second... Buy the manuals for your bike. Factory Service and Electrical.
Third...
Pull the codes and follow proper troubleshooting procedures for the code found. As you know parts for these things are not cheap. Stop throwing parts at it.
 
1 - 5 of 5 Posts
Top