Harley Davidson Forums banner
1 - 11 of 11 Posts

· Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have an 05 Ultra Classic with the 88ci. I'll be riding and out of the blue she will die like I turned off the ignition or hit the kill switch. After I get off the side of the road she will not start. When I do try to start her she just wears down the battery like I have the ignition switch turned off. When I turn off then on the ignition switch I can't even hear the fuel pump prime. I have sat there for a couple of hours and then I can get her to start. A couple of times I have towed her home and she wouldn't start for a week then all the sudden she comes to life. I have gone through all of my connections cleaning and using dielectric grease. It is so random when it happens. Got me scratching my head and drinking a lot of whiskey. Help is needed. Thanks in advance.
 

· Retired citizen
Joined
·
26,662 Posts
Sounds to be a symptom of a failing CKP sensor.
How many miles on the bike ?
 

· Asylum Inmate
Joined
·
13,826 Posts
Had a bad battery connection do this to me.

Sent from my SM-F926U using Tapatalk
 

· Retired citizen
Joined
·
26,662 Posts
Possible ignition switch failure?
I think there was an ignition switch recall on touring models around 2005 or so. The OP could check at the H-D webpage using the bike VIN in the owners section of the site.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top