Harley Davidson Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hey guys im new to forums and was hoping i could figure out why my engine revs while im sitting at a red light. Sometimes it does it immediately after i start it and doesnt stop. I've checked my fuelpak and everything seems to be in order. I also get a lot of decel pop. it was running fine up until a month ago. Any ideas or suggestions to fix it? Thanks everyone.
 

·
Registered
Joined
·
3,520 Posts
We need a lot more information model, year, any modifications, etc. Also go the new member section and introduce yourself.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Ok thanks. 2013 Iron 883, V&H Comp Series 2-1, Performance Machine FastAir Intake, Fuelpak
Recently installed exhaust around 2 months ago and was riding around w/o O2 sensors for a couple of weeks until i bought the ext cord the stock sensors needed to reach the plug.
 

·
Registered
Joined
·
3,520 Posts
First thing I'd do is unhook the fuelpac and see if the idle problem is fixed, if so that is where to start.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
So i unplugged the fuelpak and started it up and it sounded just fine w/ no problems. Then i plugged the Fuelpak back in and started it up fine again w/ no issues. Took her out for a ride and no decel pops and she sounds good again. wonder what the issue was. Maybe one of the two plugs wasnt fully connected? Either way thanks alot guys wouldnt have figured it out w/o y'all.
 

·
SoundMan
Joined
·
576 Posts
It could be the TPS was not functioning properly. Maybe the Fuel Pack just needed to be reset. You might have achieved that by unplugging and plugging it back in.
 

·
Registered
Joined
·
43,190 Posts
Dontcha just love the cheap fixes?
 
1 - 8 of 8 Posts
Top