Harley Davidson Forums banner
1 - 18 of 18 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
Ok I have no right turn signal but my left works fine there is a constant power goin to the switch the other wire is dead all the time is my switch bad or is it something else pls help
 

·
Retired citizen
Joined
·
24,285 Posts
The brown wire is the turn signal wire, should be hot when the lights blink. Left side is violet for comparison. Also blue is the running light wire.
Swap bulbs to eliminate that as the cause.
 

·
Retired citizen
Joined
·
24,285 Posts
Check the wires in your rear fender. The front and rear turns are all on the same circuit so when one side goes both go on that side.
 

·
Registered
Joined
·
7 Posts
Hey guys I've got a 2007 heritage softail classic that has no turn signal on right side. All lights work but no turn signal. Checked all fuses and they're good. I replaced the right switch pack and still not working. Any help would be greatly appreciated. Ty
 

·
Registered
Joined
·
7 Posts
I was trying to check circuits for my front brake light switch with a tester when I crossed 2 circuits and shorted out something. Apparently it was my turn signals for the right side. I replaced both bulbs, fuse, right switch assembly and it is wired correctly. I've got a 2007 heritage softail classic. Any help would be appreciated. Ty in advance.
 

·
Registered
Joined
·
694 Posts
Are the turn signals on both sides not working or just one? Look at the responses above from this old post.
Start by checking the wiring one at a time. Look under the fender to see if any wiring has rubbed raw.
Also, stop replacing parts until you diagnose the issue.
 

·
Registered
Joined
·
7 Posts
Are the turn signals on both sides not working or just one? Look at the responses above from this old post.
Start by checking the wiring one at a time. Look under the fender to see if any wiring has rubbed raw.
Also, stop replacing parts until you diagnose the issue.
So I replaced the switch assembly cause it was easier to do that for me. The front brake switch was bad. I can't find anything wrong with wiring anywhere. Is there some kind of relay I'm missing or a turn signal module somewhere?
 

·
Registered
Joined
·
1,526 Posts
You are asking questions that make it sound like you are trying to find the electrical problem without looking at a wiring diagram.

Are you ready to stop buying parts, and troubleshoot?
 

·
Registered
Joined
·
7 Posts
If I had a detailed writing diagram I wouldn't be on here asking. I've been a Ford technician for the lady 5 years and can read a wiring diagram quite well and know how to troubleshoot and diagnose. I'm blind on my bike. Hence the questions. So if your gonna help then pls do so. And yes just the right side only
 

·
Registered
Joined
·
1,526 Posts
Nobody insulted you, so don`t get all puffed up. If you have been a professional mechanic for 5 years you should have known better than to troubleshoot by changing parts.

At the bottom of this post is a link to a wiring diagram, it is viewable online for free, provided by Harley Davidson.

While you are waiting for your Factory HD service manual to come in, try this:

Find the turn signal module, unplug the connector.

Make up a short jumper wire.

On the harness side of the connector, jump pin 1(Brown/Gray wire) to pin 6 (Brown wire), turn the ignition switch on.

Do the turn signals and indicator illuminate steady when you do this?

Wiring Diagram
 
1 - 18 of 18 Posts
Top