Harley Davidson Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
179 Posts
Discussion Starter · #1 ·
I have an 05 Electra glide classic. Get to the point. My primary been leaking out of the primary seal over and over. Some how the trany belt sprocket been rubbing and shaving the primary case. I installed the jims bearing and seal kit. It's like an upgrade on the inner primary bearing. I did some research and I still can't figure it out. I installed this seal couple times. I don't think it's the runout. Has anyone have an idea why this does this. I know it's not much info.
 

·
Registered
Joined
·
5,663 Posts
Sounds like your problem is in the transmission.
 

·
Registered
Joined
·
179 Posts
Discussion Starter · #3 ·
Sounds like your problem is in the transmission.
Tranny problem. I take a look at it. But you have maybe an idea of what it could be. But one thing I notice was when I installed a new belt sprocket. The main drive gear inner seal was coming out. Like something was pushing it out. So I installed it back in. But no oil been coming out of there. Just the primary seal.
 

·
Registered
Joined
·
179 Posts
Discussion Starter · #5 ·
Main drive gear bearing
I think you maybe right. Because I just realized there a hair crack on the main gear where the lock nut goes on for the sprocket. I did install new bearing. But looks like need new fifth gear
 

·
Registered
Joined
·
1,551 Posts
I think you maybe right. Because I just realized there a hair crack on the main gear where the lock nut goes on for the sprocket. I did install new bearing. But looks like need new fifth gear
Think I have one if you need it
 
1 - 9 of 9 Posts
Top