Harley Davidson Forums banner

1 - 13 of 13 Posts

·
tazmanken
Joined
·
41 Posts
Discussion Starter #1
I have a 2015 Tri Glide and it was delivered to me this winter so I have not had the chance to ride it on the road yet,so it only has a few miles on it,anyway the other day I needed to move it in my garage to clean up some water and after backing it up I had this bad oil burning smell coming from it from under the seat,only backed it up a few feet,is this smell normal for a new T/G or is there something else wrong? Im hoping its because its new and will stop after putting some miles on it this summer. Thanks for the help. :eek Ken
 

·
Registered
Joined
·
39,467 Posts
New motors have an odd smell when they get warm due to the powdercoating being cooked.

Could that be what you are smelling?
 

·
Fat Guy on the Ultra
Joined
·
5,388 Posts
Possibly the assembly oil or exhaust packing burning off too. New bikes do smell for a few hundred miles until all stuff burns off.
 

·
VA Fender Bender
Joined
·
5,551 Posts
what was the question about reverse?
 

·
Registered
Joined
·
11,033 Posts
I would call your dealer and ask them--and go on record as having asked about the unusual smell.

In recent years I have had 3 new Harleys and never noticed any odd or unusual smells when they were new. Course, none of mine had a reverse so I don't know....,
 

·
Registered
Joined
·
39,467 Posts
I would call your dealer and ask them--and go on record as having asked about the unusual smell.

In recent years I have had 3 new Harleys and never noticed any odd or unusual smells when they were new. Course, none of mine had a reverse so I don't know....,
Any of them with powdercoated motors?
 

·
Registered
Joined
·
39,467 Posts
Yes. Both mine were powdercoated, and they had a "new engine" smell to them for the first 1000 miles or so.
 

·
Registered
Joined
·
11,033 Posts
Yes. Both mine were powdercoated, and they had a "new engine" smell to them for the first 1000 miles or so.
Well, then my Fat Bob did have a lot of powdercoating--not so much on my 1200 Sporty or RG--and maybe my "sniffer" isn't as good as it should be but I never noticed any "new" type of smell from the motor or anywhere else.
 

·
tazmanken
Joined
·
41 Posts
Discussion Starter #10
It might be the assembly lube,it was for sure coming from under the seat after backing up.
 

·
tazmanken
Joined
·
41 Posts
Discussion Starter #11
what was the question about reverse?
I have a 2015 Tri Glide and it was delivered to me this winter so I have not had the chance to ride it on the road yet,so it only has a few miles on it,anyway the other day I needed to move it in my garage to clean up some water and after backing it up I had this bad oil burning smell coming from it from under the seat,only backed it up a few feet,is this smell normal for a new T/G or is there something else wrong? Im hoping its because its new and will stop after putting some miles on it this summer. Thanks for the help. Ken
 

·
tazmanken
Joined
·
41 Posts
Discussion Starter #12
just a update,after putting 100 miles on it the smell is gone,a ton of fun to ride :)
 

·
Registered
Joined
·
827 Posts
New bike smell is a little different than new car smell. Oil on pipes, corrosion protection oil coatings burns off, etc. Isn't usually a problem
 
1 - 13 of 13 Posts
Top