Harley Davidson Forums banner
1 - 20 of 29 Posts

·
Registered
Joined
·
280 Posts
Discussion Starter · #1 ·
I have a '07 Harley radio that i am not able to hear any sound through the speakers. When i turn on the radio, the screen comes on, volume control shows turning up and down and changing stations also but still have no sound at all. Is there something i can do or is this a "send in to get it fixed" deal? Are these radios repairable or is it time to look for another radio? Hopefully this radio can be repaired. Thanks for any of your help.
 

·
Registered
Joined
·
142 Posts
Do you have a speaker switch that switches off the external speakers when using helmet intercom speakers? If so, maybe the switch is bad (or just has external speakers switched off, maybe???).
 

·
Mississippi Cajun
Joined
·
24,958 Posts
Do you have a speaker switch that switches off the external speakers when using helmet intercom speakers? If so, maybe the switch is bad (or just has external speakers switched off, maybe???).
That'd be my first guess.
 

·
Registered
Joined
·
280 Posts
Discussion Starter · #4 ·
I don't use a intercom helmet and i have the Classic, which doesn't have the speaker switch like the Ultra, located near the ignition. There isn't a speaker switch on the radio that i know of, is there?? Thank you for the feedback. My ears are open.
 

·
Retired citizen
Joined
·
24,277 Posts
Do the radio diagnostic program . With the ignition off hold in any two buttons while turning the ignition on at the same time , that gets you into the radio diagnostics . That procedure is in your owners manual I believe .
 

·
Registered
Joined
·
280 Posts
Discussion Starter · #6 ·
I just did the diagnostic and it gave me a "B2017 code" and said "FL Speaker Open". What is that telling me? Open connection inside the radio??
 

·
Retired citizen
Joined
·
24,277 Posts
Left speaker is bad or the wire came off , FL is Front Left .
 

·
Retired citizen
Joined
·
24,277 Posts
Try bipping on the fairing with the palm of your hand to see if ya hear anything .
 

·
Registered
Joined
·
280 Posts
Discussion Starter · #9 ·
I have a 08 ultra and a 07 classic. The 07 classic is the one with no sound. i plugged the 07 classic radio in the 08 ultra and there is no sound. I took the good radio out of the 08 ultra and tried it in the 07 classic and the radio and speakers work. Does that mean an open in the speaker circuit inside the radio itself? Just askn, i hope not.
 

·
Retired citizen
Joined
·
24,277 Posts
Yup , sounds like an open speaker circuit inside the radio . Take the radio to the dealer , they'll send it in to the radio company for repairs . Comes back like brand new .
 

·
Retired citizen
Joined
·
24,277 Posts
Ok thanks. What should i expect to pay for something like that, do you have an idea??
I think it's a set charge , like $ 225.00 maybe . Call the dealer and ask what they charge if they don't have to do any of the work .
 

·
Registered
Joined
·
280 Posts
Discussion Starter · #13 ·
Will do Schmidtys. Thank you very much for your helpful sugestions. Now i know what i have to do. I was afraid the trouble was going to be in the radio. You have a good one. Enjoy each ride we get!
 

·
Retired citizen
Joined
·
24,277 Posts
Will do Schmidtys. Thank you very much for your helpful sugestions. Now i know what i have to do. I was afraid the trouble was going to be in the radio. You have a good one. Enjoy each ride we get!
Yea , supposed to be in the 70s here today !!! Everyone is buggin' me to get their bikes back already !
 

·
Registered
Joined
·
7,340 Posts
For $225 you can buy a pretty nice stereo. The newer have bluetooth interfacing for your phone as well as iPod controls, usb ports for jump drives. All sorts of stuff to play with.

If you want the stock radio, I get it. But it is something to think about.
 

·
Retired citizen
Joined
·
24,277 Posts
That price was just from memory , I think that also included removal and reinstall too .
 

·
Registered
Joined
·
280 Posts
Discussion Starter · #17 ·
I will make a call and see. May look into another radio, depends how cost effective it is. Not opposed to getting away from the harley radio. Will keep you posted if interested. Thanks guys!!
 

·
Registered
Joined
·
12 Posts
Just pulled my radio out and sent it to Iron Cross Audio yesterday, $250 flat rate repair with a 1 year warranty, my local dealer was close to $400 for an exchange unit and 90 day warranty.
 

·
Registered
Joined
·
280 Posts
Discussion Starter · #19 ·
I made a call to my local stealership and they want $275 paid up front to send it in for a evaluate and repair. If it takes more to fix it, could be an additional charge. (Open your check book again kind of theroy.) Here is the interesting part: he said after i install the repaired radio i have to bring the bike in to have them reflash the ECM so it will recognize the radio install. Otherwise it wont turn on. Isn't that wonderful. What i don't understand is i swapped a radio out of my '08 ultra and installed it in the '07 and the '08 radio plays just fine without the reflash. Oh, reflash charge is $37.50. Go fiqure!!!!!!!!! Can someone explain to me what is really going on here. Thank you in advance for any knowledge on this. Don't know what to do on this deal.
 

·
Registered
Joined
·
12 Posts
I not thinking the if the existing radio is repaired it would need to be re synced with the bikes ecm, but I could be wrong. I will update when my radio gets back
 
1 - 20 of 29 Posts
Top