Harley Davidson Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
233 Posts
Discussion Starter · #1 ·
I just downloaded the newest update from the Harley web site. It pretty much killed my volume and now my radio is cutting out non stop. My question does anyone know how to fix this? I am going insane with no or little volume when riding. I have installed a 300 watt amp and updated speakers and all was working top notch for months but today when I downloaded this I am getting all of these issues. Is there a way to uninstall this? There a way to go back to the other program before the install. Please please someone have an answer for This. Getting ready to leave for a five day trip in 3 days. I need tunes. Really in a jam here I need to get this fixed
 

·
Road Junkie
Joined
·
2,020 Posts
Did you download the correct version for your bike and location? I think I recall another Canadian having difficulties with the North America version. Can also search for HD Infotainment on this site for some great help.

Update: Found the link to the international software downloads (Software Downloads | Harley-Davidson® Infotainment System | Harley-Davidson International), but it indicates Canada does use the North American version. I maintain a library of previous versions for the Premium Radio just in case I need to back track. If you can't find a direct download, PM me and I'll try to email or use DropBox. For what it's worth, I've got 2200 miles of riding time with the new version and no problems other than an occasional random switch from Media to Radio, but that is happening much less frequently than the previous version.
 
1 - 3 of 3 Posts
Top