Harley Davidson Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi, I just put on LEDS on my 883 and turned on my motorcycle and the red key is now on speedometer. No fob, or alarm system and still runs.

What does this mean?
Could it be the new LEDS causing it?
Also, the blinking frequency is more rapid. It this normal?
 

·
Registered
Joined
·
1,096 Posts
Did these leds come with instructions? I put the Custom Dynamics Pro series on my Ultra. The last step was to set the key switch to run, withe the run stop switch set to stop. Then activate the four way (Hazard lights) for 4 or 5 minutes. Then turn off everything. Lastly start the bike as normal. This resets the computer?? I have yet to put them on the Sportster,(XL 1200 C) but that will be my next upgrade for it.
EDIT: I know my 17 Sporty requires a load equalizer (the green box) from Custom Dynamics.
 
  • Like
Reactions: WiSeNhEiMeR

·
Registered
Joined
·
38,990 Posts
What year motorcycle? Older bikes werent designed for LED turn signals. Newer bikes need to be programmed to work with LED signals.
 

·
Registered
Joined
·
1,096 Posts
What year motorcycle? Older bikes werent designed for LED turn signals. Newer bikes need to be programmed to work with LED signals.
2013 in the title... I missed that too, at first. What year did they come out with plug n play?
 
  • Like
Reactions: WiSeNhEiMeR

·
Registered
Joined
·
38,990 Posts
2011 is when MoCo made the BCM programmable to accept LEDs on Big Twins.
2014 for Sportsters.

2013 Sportster, you will need a load balancer.
 

·
Registered
Joined
·
2 Posts
I’m just experiencing something similar. I have a 2010 sportster 883 i put plug n play led headlight and front and rear blinkers in and now my little red key light comes on, bike runs and rides fine just annoying looking at it! Has anyone come up with a way to fix this?
 

·
Registered
Joined
·
1,096 Posts
I’m just experiencing something similar. I have a 2010 sportster 883 i put plug n play led headlight and front and rear blinkers in and now my little red key light comes on, bike runs and rides fine just annoying looking at it! Has anyone come up with a way to fix this?
Umm, the fix is stated in the post just prior to yours:
2011 is when MoCo made the BCM programmable to accept LEDs on Big Twins.
2014 for Sportsters.

2013 Sportster, you will need a load balancer.
I know Custom Dynamics makes and sells them: Custom Dynamics Motorcycle LED Lights
 

·
V-Twin Junkie
Joined
·
268 Posts
Hey guys and gals, if anyone needs a load balancer, I have two still new in the box that I bought before realizing that the BCM on my bike would manage the LEDs. Free for the price of shipping. Happy to help anyone who needs one.
 

·
Registered
Joined
·
2 Posts
Hey guys and gals, if anyone needs a load balancer, I have two still new in the box that I bought before realizing that the BCM on my bike would manage the LEDs. Free for the price of shipping. Happy to help anyone who needs one.
i am definitely interested could you message me and we can set something up please!
 
1 - 10 of 10 Posts
Top