Harley Davidson Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello guy’s
I have a Dyna Street Bob from 2017
My right turn signals doesn’t work.
The left side functions fine.
The running lights in front are normal, and the hazards work normally. The only thing that doesn't work is the right turn signal.
Since the lights work in other modes, maybe something happened to the switch?
I washed the bike and the day after it didn’t work. I tried to change the bulbs and cleaned the switch with contact cleaner
I hope some of the gurus here can give me some insight.
 

·
Registered
Joined
·
7,430 Posts
Water and electricity do not get along. Depending on how much water was used when you washed your bike, some may have gotten into the fuse area. Pull the fuses one at a time, clean and dry the fuse. Spray contact cleaner into the fuse slot and let dry. Add dielectric grease to the prongs on the fuse and reinstall. Even if this does not solve your current issue, it is not a bad idea to do this periodically anyway since the fuse area gets dirty quickly.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Water and electricity do not get along. Depending on how much water was used when you washed your bike, some may have gotten into the fuse area. Pull the fuses one at a time, clean and dry the fuse. Spray contact cleaner into the fuse slot and let dry. Add dielectric grease to the prongs on the fuse and reinstall. Even if this does not solve your current issue, it is not a bad idea to do this periodically anyway since the fuse area gets dirty quickly.
Thanks i tried this morning, no luck but now it’s clean😊. Do you know if there are more than 3 fuses on a bike like this ? I’m new to all this the 3 fuses I found on the opposite site of the battery
 

·
Just Ride
Joined
·
3,862 Posts
Time for a manual.
 
  • Like
Reactions: RJ64 and Kainam

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
I changed the bulbs that’s not it but thanks.
when it stand still for 2 days, the turn light work but only the first time I press the switch but If I blink to the left and then right again it’s not working
 

·
Registered
Joined
·
49 Posts
You may have a bad switch...use a test light to check the switch...

If you press the left signal, let it blink, then press the right signal, does it stop the left from blinking...? If yes, and it does it consistently the right switch might be good. If not, the switch is bad...
 
1 - 7 of 7 Posts
Top