Harley Davidson Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I recently replaced the fuel line that goes bad in my '06 fxst. after re-assembling everything I try to start it and nothing doing! I now have the security light coming on as normal when the ignition is turned on, then goes out, then a few seconds later it comes back on for a few seconds and goes back out. bike cranks, fuel pump is running, everything else seems normal other than it won't run. Hope someone can help!
 

·
Registered
Joined
·
7,340 Posts
Security light is also the diagnostic code indicator. Run the code sequence as described in the electrical section stickies. Your bike will display the dtc in the odometer screen.

Post the code.
 

·
Retired citizen
Joined
·
23,364 Posts
If it starts for a few seconds then shuts off means you have to re-marry the FOB to the ECM.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I cycled the ignition with the speedometer unplugged while checking for fuel leak in the tank with the fuel pump part way out. everything is plugged back in now though. looking up codes, maybe the speedo being unplugged deactivated a relay.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Security light is also the diagnostic code indicator. Run the code sequence as described in the electrical section stickies. Your bike will display the dtc in the odometer screen.

Post the code.
code u1255. I cycled the ignition switch with the speedo unplugged to check for the leak with the fuel pump partially out, so does something need reset?
 

·
Retired citizen
Joined
·
23,364 Posts
Unplug the maxi fuse for about 10 minutes, that'll reset the system. Large orange fuse in a plastic retainer.
 

·
Registered
Joined
·
39,502 Posts
You can clear the codes by pressing in the odometer reset button while the code is showing for 5 seconds until the word clear comes up.
 
1 - 8 of 8 Posts
Top