Harley Davidson Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
225 Posts
Discussion Starter #1
So I have the 07 EG classic up on a jack with the rear tire removed and it's getting replaced at the shop. Since the bike is down for maintenance I decided to knock out a few odds and ends. While adding the tender pigtail I accidentally shorted the battery with my wrench. Quickly pulled it away but now I have no headlight, no radio, no dash lights, and the bike will not turn over. I have pulled the side panels and checked the fuses with my multimeter, they all him out fine. I pulled the 40 ohm main fuse and it is fine.

Any ideas what else I should be checking? I'm hoping nothing too major is wrong!

Thanks, this forum has helped me out numerous times on several different issues over the years.

Gman!


Sent from Motorcycle.com Free App
 

·
Banned
Joined
·
71 Posts
So I have the 07 EG classic up on a jack with the rear tire removed and it's getting replaced at the shop. Since the bike is down for maintenance I decided to knock out a few odds and ends. While adding the tender pigtail I accidentally shorted the battery with my wrench. Quickly pulled it away but now I have no headlight, no radio, no dash lights, and the bike will not turn over. I have pulled the side panels and checked the fuses with my multimeter, they all him out fine. I pulled the 40 ohm main fuse and it is fine.

Any ideas what else I should be checking? I'm hoping nothing too major is wrong!

Thanks, this forum has helped me out numerous times on several different issues over the years.

Gman!


Sent from Motorcycle.com Free App
What is your battery's voltage???


:coffee:
 

·
Registered
Joined
·
225 Posts
Discussion Starter #4
What is your battery's voltage???





:coffee:

Okay.... So I'm a dumbass.... I just unplugged the battery tender and my headlight is now working.... I tightened up the battery terminals a little and she just fired.

Sometimes I guess stepping away and coming back later is the best solution. Thank you!


Sent from Motorcycle.com Free App
 

·
Banned
Joined
·
71 Posts
Okay.... So I'm a dumbass.... I just unplugged the battery tender and my headlight is now working.... I tightened up the battery terminals a little and she just fired.

Sometimes I guess stepping away and coming back later is the best solution. Thank you!


Sent from Motorcycle.com Free App
Check for a code now, should be a low battery voltage code stored, clear it. :thumbsup


:coffee:
 
1 - 6 of 6 Posts
Top