Harley Davidson Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter · #1 ·
Speedometer stopped working on my 2011 FLSTC.
Noticed that gear selection on the display is blank but rpms are working.
No check engine lights but almost dies at idle now.
Speed sensor on transmission shot?
Feedback please.
 

·
Retired citizen
Joined
·
24,219 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter · #7 ·
Also, remove the maxi-fuse then two bolts to move the starter out of the way.
I need to get a 3/16 hex socket. Mine is worn out so I might get a new set.
Should I replace the trans fluid also while I am doing this?
I only have a 1000 miles on the fluid and can't believe there is that much crud in the fluid.
 

·
Retired citizen
Joined
·
24,219 Posts
If you find crud in the fluid then I'd change it. I use 85/140 gear lube in the trans, shifts easier and quieter.
 

·
Registered
Joined
·
113 Posts
Discussion Starter · #9 ·
Ok. Got it out and there was a metal sliver on it.
I drained the fluid and saw another sliver in there too.
The drain plug magnet had nothing on it so I put my screw driver on the magnet and nothing. It has no magnetic pull whatsoever so I guess I am going to purchase a new magnetic plug.
 

·
Registered
Joined
·
113 Posts
Discussion Starter · #10 ·
Got new drain plug and transmission fluid at dealer. Cost 10.50 for everything.
I put it back together, filled with fluid and speedometer and gear selector on display is working again!
Thanks SCHMIDTY!
You are a valuable asset to this community! 🇺🇲
 

·
Retired citizen
Joined
·
24,219 Posts
I'm not sure about using GL5 in a gearbox.
 
1 - 12 of 12 Posts
Top