Harley Davidson Forums banner

Speedometer Tachometer Upgrade

1069 Views 1 Reply 2 Participants Last post by  RideADyna
I have a 2014 Iron 883 and recently purchased and had the dealer install a Speedometer Tachometer Upgrade. It works great however the range functionality does not appear to be working as it displays "r----" for range. I was told that it should change after 50 miles however, I have passed the 50 mile-mark from when it was installed and there is still no fuel range indicated, just, "r----" and I am wondering if anyone else has had this issue.
I realize that this is quite a specific issue, but if anyone else recalls ever having this issue, I sure would be interested in how you solved this or whether it resolved without taking to the dealer.

Thanks in advance for any info, guys!
- David
1 - 2 of 2 Posts
When you programmed the new tach speedo did you program the tank size. If not then you did not do it right. Ask me how I know. Once I figured that out my range shows up. Its gets a bit more accurate with more fillups. The problem with getting the Range, etc all to work is having that jumper correct under the seat. I put it wrong the first time so I took it off and rode a couple weeks without it. Then I finally got a bit of help in doing it right and ordered a new adapter plug and everything went smooth.
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.