Harley Davidson Forums banner

41 - 52 of 52 Posts

·
Addicted Since 2010
Joined
·
7,900 Posts
Discussion Starter #41
Good job. I’m digging those black lowers! Black triple tree looks good, too. Now, get those turn signals off of the bars. Mount them lower.

P.S.
you have a girlfriend don’tcha? Kitchen is too clean to be a bachelor pad.
Hmm. Never thought of moving the blinkers but it might look good. I am really digging the trees and lowers being black but need to decide now if I want to get black calipers... the gray looks ok but black may look better.

I do have a gf however believe it or not I'm an OCD bastard so its clean on my behalf. She is worse than I am though so I do have to stay on the top of my game!
 

·
Gypsy on Parade
Joined
·
4,903 Posts
I moved mine on my Dyna to the lower triple tree even before I installed my apes. Just makes it look cleaner IMHO. Yours s looking good after showing some love!
 

·
Registered
Crazy Cat Man
Joined
·
665 Posts
Yep I got mine down off the bars, on my '19 Iron 1200 that I traded in for Daisy, and it looked waaaaaaaaay better. Nothing wrong with OCD when it comes to cleaning. I make my cats clean since they there all day free loading off me haha.
 

·
Registered
Crazy Cat Man
Joined
·
665 Posts
They make caliper paint instead of buying new calipers, FYI. I'm thinking of doing mine red on Cat-Rat since the rest of the painted parts are red.
 

·
Addicted Since 2010
Joined
·
7,900 Posts
Discussion Starter #45
I moved mine on my Dyna to the lower triple tree even before I installed my apes. Just makes it look cleaner IMHO. Yours s looking good after showing some love!
Thank you! I'll definitely look up some photos online and see what I think.
 

·
Addicted Since 2010
Joined
·
7,900 Posts
Discussion Starter #46
They make caliper paint instead of buying new calipers, FYI. I'm thinking of doing mine red on Cat-Rat since the rest of the painted parts are red.
Shhh!!!! That solution doesn't give me an excuse to upgrade!🤣
 

·
Addicted Since 2010
Joined
·
7,900 Posts
Discussion Starter #47
Yep I got mine down off the bars, on my '19 Iron 1200 that I traded in for Daisy, and it looked waaaaaaaaay better. Nothing wrong with OCD when it comes to cleaning. I make my cats clean since they there all day free loading off me haha.
Any pics of the iron still with them on the forks?
 

·
Registered
Crazy Cat Man
Joined
·
665 Posts
I looked and I don't seem to have any pics after I changed their location.
 

·
Addicted Since 2010
Joined
·
7,900 Posts
Discussion Starter #49
Finally got the front end all buttoned up and despite living in Upstate NY in January I got it out for a quick test ride. During normal driving conditions the suspension seems very similar, however I think with some tight twisties and more aggressive riding I will start noticing a difference. It does seem to be a bit smoother and not as much dive on braking. Overall I am happy so far.
In the process of all this though, unfortunately I seem to have lost half my gauge lights. Right blinker, neutral and high beam light don't work. Only the oil and left blinker do...so now I need to see what that's all about.
 

·
Registered
Joined
·
1,565 Posts
Finally got the front end all buttoned up and despite living in Upstate NY in January I got it out for a quick test ride. During normal driving conditions the suspension seems very similar, however I think with some tight twisties and more aggressive riding I will start noticing a difference. It does seem to be a bit smoother and not as much dive on braking. Overall I am happy so far.
In the process of all this though, unfortunately I seem to have lost half my gauge lights. Right blinker, neutral and high beam light don't work. Only the oil and left blinker do...so now I need to see what that's all about.
Sounds like one of the ground wires got disconnected in the gauge cluster... look for a cold solder joint (dull grey vs shinny silver).
 

·
Addicted Since 2010
Joined
·
7,900 Posts
Discussion Starter #51
Sounds like one of the ground wires got disconnected in the gauge cluster... look for a cold solder joint (dull grey vs shinny silver).
So I looked into it further. I have an LED load resistor for the turn signals under the seat. Basically interrups the wiring harness to the TCM. Seems as though something is acting up in there because I played around with it and all the lights are now working. I am going to keep an eye on it and maybe replace it. Worst case ill go back to regular bulbs or get LEDs with load resistors built in.
 

·
Addicted Since 2010
Joined
·
7,900 Posts
Discussion Starter #52
More progress. Carb is fully torn apart, cleaned, and rebuild shall begin! Photos are all scrambled but rest assured it is clean!
 

Attachments

41 - 52 of 52 Posts
Top