Harley Davidson Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Making a left hand turn at a residential intersection from a stop sign, my 2007 FLHX coughed then all the power to the bike flat out died. I realized I was in 2nd gear and after take off, I quickly downshifted and that's when it all occurred. This morning I tore everything I cld get at apart and made sure there was nothing broke, fractured, disconnected or filthy dirty. Cleaned any and all contacts or contact points I cld get at and put it all back together. I rode it to work this morning and it ran flawlessly...penny for everybody's thoughts.
 

·
Super Moderator
Joined
·
4,445 Posts
My 2013 mysteriously died on me 2 times. Complete power failure but successful restart after about 1 minute. Once I was really getting on it and suspected I hit the limits of a potential speed governor. Second was just out of the blue doing about 75 on the interstate. No fault code or subsequent clues either.
Have 10K and it only happened 3 times (the 3rd was a fuel issue, as in.. ran out) Always wondered what the heck happened with the other 2 times.
 

·
Call me Gig.
Joined
·
3,964 Posts
Can't help the OP but for ematicic, the governor doesn't shut the bike down completely. Reduce the throttle and the engine kicks back in.

Which made me always wonder why they don't just program it not to rev higher than the set RPM. No power loss just no more revs.
 

·
Registered
Joined
·
153 Posts
My 09 RK lost all power and would only idle, no throttle response. Turned out to be the connection on the left side of the throttle body. cleaned and added diaelectric grease...hopefully that's the end of that problem!
 

·
Registered
Joined
·
87 Posts
Didn't you guys get the HD Notice?

When they die you must bury them and buy a new one.

:laugh:rollin:bowrofl::silly:thumb
 

·
Registered
Joined
·
1,478 Posts
Making a left hand turn at a residential intersection from a stop sign, my 2007 FLHX coughed then all the power to the bike flat out died. I realized I was in 2nd gear and after take off, I quickly downshifted and that's when it all occurred. This morning I tore everything I cld get at apart and made sure there was nothing broke, fractured, disconnected or filthy dirty. Cleaned any and all contacts or contact points I cld get at and put it all back together. I rode it to work this morning and it ran flawlessly...penny for everybody's thoughts.
You were in 2nd gear and it died leaving a stop sign and now you wonder what happened???? :dunno
 

·
Hard Member
Joined
·
3,242 Posts
My 2013 mysteriously died on me 2 times. Complete power failure but successful restart after about 1 minute. Once I was really getting on it and suspected I hit the limits of a potential speed governor. Second was just out of the blue doing about 75 on the interstate. No fault code or subsequent clues either.
Have 10K and it only happened 3 times (the 3rd was a fuel issue, as in.. ran out) Always wondered what the heck happened with the other 2 times.
You know, the other day you were going so fast your angel couldn't catch up and had to ride beotch on my bike.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #8
Illinois William...it died after I pulled the clutch in (still had power at that point). It didn't die cuz I was an idiot and left from a stopped position in 2nd gear. Lemme guess...never done that right??? There's a difference between dying from a wrong gear selection or dumped clutch and completely losing electrical...just sayin brother.
 

·
Retired citizen
Joined
·
23,643 Posts
Clutch switch going bad ?
 

·
Registered
Joined
·
184 Posts
Hello, I dont kmow if you have Identified your specific problem but I Had almost the exact situation with my brothers 09 FLHX while he was overseas. I was keeping his bike for him becouse he wanted it ridin while he was gone so I would take it out a time or two a week. Then one morning on my way to work lo and behold leaving a stop light I throttled up took off and when I went to second it died. After that it rode well for a couple weeks then it started to funky slow starts and stalling at wierd times. I took it to the dealer who after a day of trouble shooting determined the voltage Regulater was going out and its symptoms were becouse in its first dying throws the voltage was spiking every so often. Gradually the other issues were popping up as it started failing further so they cleaned the and tightened all connections installed A new voltage regulater and the bike was fixed.
 

·
Retired citizen
Joined
·
23,643 Posts
Yep, good call on the regulator.
 

·
Señor Member
Joined
·
19,668 Posts
Illinois William...it died after I pulled the clutch in (still had power at that point). It didn't die cuz I was an idiot and left from a stopped position in 2nd gear. Lemme guess...never done that right??? There's a difference between dying from a wrong gear selection or dumped clutch and completely losing electrical...just sayin brother.

This is a clearer description. I had the same confusion as Willie.
 

·
Senile Member
Joined
·
1,713 Posts
Check batt power, it should be 13 volts.

I'd check the connector to the regulator. Pull it apart and then put it back together. You want to hear a click when it locks together. If that was it, put a couple zip ties on the connector to hold it together.

The batt may need a jump start.

If the regulator isn't feeding the battery, then the bike will eat the battery and die.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #15
Sorry for any confusion gents...
Knock on wood, bikes run fine ever since the incident and I tore as much as I cld get at apart and cleaned. I will keep an eye on the regulator tho...thanks all for the input and if anybody's got more, keep it coming please.
 
1 - 15 of 15 Posts
Top