Harley Davidson Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2006 Electra Glide Classic EFI. It had a TSM in the bike, and wanted to install TSSM. The problem I am having is I can't get it to respond to the procedures in the manual. I have tried the run switch in the off prosition and the key ON OFF ON OFF ON OFF, and press left turn signal twice and no blinker flash or anything. Then tried run switch in run switch on and try start nothing except in the odometer there is what looks like and upside down F IP. Put the tsm back in and it will respond to the ON OFF ON OFF ON, and press left turn signal twice with one flash of the turn signals. What the hell am I doing wrong.
 

·
Registered
Joined
·
39,564 Posts
All I can suggest is to try again, if all else fails, bring to dealer.

Tssm Marriage
1 Set Run switch to Run

2 Turn Ignition key On-Off-On-Off-On-Off-On and then toggle
the Left Turn Signal switch twice.

3 Turn Ignition key Off-On Verify the Check Engine lamp and Security Lamp illuminate
briefly and then turn off Security lamp will not illuminate on non-security
(TSM) Twin Cam models.

4 Attempt normal start one time. Engine starts and stalls immediately. check engine
lamp stays on. Password has not been learned and sets trouble code P1009, thus stopping fuel
flow.

5 Wait 10 seconds Security Lamp remains lit for V-Rod and TC88 with TSSM. Lamp will not be on for TC88 TSM models. ECM enters Password Learning mode for 10 minutes.
Do Not cycle the ignition or disrupt power.

6 Wait until Security Lamp turns off or a minimum of 10 minutes has passed.

7 Quickly (within 2 seconds) turn Ignition key OFF-ON Security Lamp remains lit for V-Rod and TC88 with TSSM. Lamp will not be on for TC88 TSM models.

8 Wait until Security Lamp turns off or a minimum of 10 minutes has passed. Password Learning mode for 10 minutes. Do Not cycle the
ignition or disrupt power.

9 Quickly (within 2 seconds) turn Ignition key OFF-ON Security Lamp remains lit for V-Rod and TC88 with TSSM. Lamp will not be on for TC88 TSM models.

10 Wait until Security Lamp turns off or a minimum of 10 minutes has passed. Password Learning mode for 10 minutes. Do Not cycle the ignition or disrupt power.

11 Quickly (within 2 seconds) turn Ignition key OFF-ON Security Lamp light and then turn off. Lamp will not be on for TC88 TSM models.

12 Turn Ignition switch OFF. Wait 15 seconds. Turn Ignition switch ON and start engine to confirm the Password Learn Procedure is successful. Engine will start and remain running
If engine immediately stalls and fails to restart the Password Learning mode was not successful. Start over at step 1.
 

·
Registered
Joined
·
212 Posts
A bit of warning. This procedure takes a while to do. If you do it mulitple times, you'll end up with a dead battery.

PULL YOUR LIGHT FUSE FIRST. KEEP YOUR BIKE ON A BATTERY TENDER FOR THE ENTIRE PROCEDURE.

Trust me on this one. ;)
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Found the problem. They sent wrong part. The one they sent is to be mounted horizonally, and I needed on that is mounted virtically.
So it thought the bike was laying over to for. Suppose to send me another TSSM.
 

·
Just passing thru
Joined
·
6,636 Posts
Found the problem. They sent wrong part. The one they sent is to be mounted horizonally, and I needed on that is mounted virtically.
So it thought the bike was laying over to for. Suppose to send me another TSSM.
Thats a tricky one. Thanks for getting back to us with the answer.
 

·
Retired citizen
Joined
·
23,374 Posts
Is it a new TSSM ? If not it ain't gonna work.
 

·
Registered
Joined
·
3 Posts
The reason I'm replacing the TSSM is because under a load it cuts out and backfires through the Throttle Body and it have a code p01007 map sensor I tested the voltage and I am getting 5v to it so that's the reason for replacing the TSSM
 
1 - 10 of 10 Posts
Top