Harley Davidson Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
03 sportster. Signals will not light up..will not flash.
All other lights are working fine..bulbs check out ok..need help!
 

·
Registered
Joined
·
828 Posts
Has any work been done to the bike since the turn indicators last worked? Has the rear tire been removed and reinstalled? If this is a XLC there is a riser below the handlebar clamps that all the wiring goes through. That chrome box is kinda "touchy", Its easy to create a short or even to cut a wire when installing that cover. If i remember correctly the XLC also has a turn signal control (flasher) on it. Will the signal lights come on at all? When the turn switch is activated, does any of the lights come on but don't blink?

I'm not in any way attempting to question you to death over this but, more the more information you provide makes troubleshooting via keyboard much less difficult.

I spent a lot of time bringing a '03 Sporty back to life last year. I no longer have the service manual for it. That manual will have the wire diagrams in it. (Factory Service manual) I have little faith in the Clymers or other aftermarket manuals. They have mistakes in them!
 

·
Kicking Rocks...
Joined
·
11,096 Posts
Start simple... bulbs, fuses, grounds and connections. A basic multi meter can be a huge help. Don't trust eyeballing fuses and connections, test them with a meter. After you check the basics, you can move to the next items in the chain.
 

·
Retired citizen
Joined
·
22,887 Posts
Also check the turn signal canceller (TSM) mounted on the rear fender under the seat. Check the connector and wiring.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Has any work been done to the bike since the turn indicators last worked? Has the rear tire been removed and reinstalled? If this is a XLC there is a riser below the handlebar clamps that all the wiring goes through. That chrome box is kinda "touchy", Its easy to create a short or even to cut a wire when installing that cover. If i remember correctly the XLC also has a turn signal control (flasher) on it. Will the signal lights come on at all? When the turn switch is activated, does any of the lights come on but don't blink?

I'm not in any way attempting to question you to death over this but, more the more information you provide makes troubleshooting via keyboard much less difficult.

I spent a lot of time bringing a '03 Sporty back to life last year. I no longer have the service manual for it. That manual will have the wire diagrams in it. (Factory Service manual) I have little faith in the Clymers or other aftermarket manuals. They have mistakes in them!
Yea. I followed the manual until it stopped making sense..ok it started after I found a break in the wiring from rear left turn signal..i pulled the rear left turn sig light stem..I reconnected wiring..and it worked for abt 3 days then both rt and lt front and back will not light up..the original break in wire was caused by rear tire...so I used manual and checked the access fuse with meter..and checked pins they said check..fuses ok..bulbs ok...maybe my reconnect under back rear fender failed..dont know..bike is a 03 sportster hugger..had rear tire off last summer..that's abt it I guess..
 

·
Registered
Joined
·
828 Posts
Yep, I would start by inspecting the splice that you previously made. Then check all the related wires in and around the rear tire. It had eaten one wire so, some others may been chewed as well. Look closely at the wires mentioned in the other post as well.
 
1 - 6 of 6 Posts
Top