Harley Davidson Forums banner

4981 - 5000 of 5173 Posts

·
old scoot coot
Joined
·
3,600 Posts
i went to shop a while ago and put new rear 02sensor on fury.. of course i had to take it out in the rain for confirmation run. runs great, no codes yadda yadda. i wiped it down when i got back, changed my shirt and later i'll go out and clean wheels and nww tires. that dude is doing day trip duty for a couple of weeks after the hurricane rain stiops go fury!:cool:
 

·
Registered
Joined
·
251 Posts
i'd bet they will pull or pry right off. just easy on the silicone. yep you guys are really gettin snazzy. that's winter time stuff. summer is for getting them nasty dirty.:cool:
Got a bike show coming up labor day weekend and I'm getting her ready for entering this year. Last year the Rat bike lost out to a '63 Sporty with original parts on it. Didn't feel bad about that cause it was a cool bike.
 

·
Registered
Joined
·
1,100 Posts
i'd bet they will pull or pry right off. just easy on the silicone. yep you guys are really gettin snazzy. that's winter time stuff. summer is for getting them nasty dirty.:cool:
Here lately, it's been north of 100 every weekend. So I've been playing wax-on, wax-off while in the air conditioned garage. Here at Christmas time, its often in the 70*s. Like everything else that Comiphorna is assbakwards to the normal world!:cool:
 

·
old scoot coot
Joined
·
3,600 Posts
Here lately, it's been north of 100 every weekend. So I've been playing wax-on, wax-off while in the air conditioned garage. Here at Christmas time, its often in the 70*s. Like everything else that Comiphorna is assbakwards to the normal world!:cool:
i could handle your weather. 70's at christmas, hell yea! i just don't want to move to get it. :D
 

·
Registered
Joined
·
251 Posts
I have the small bolt covers on. Some of the other ones don't fit well so they might not even go on. here is a pic of the right side. I like the look with the smaller air cleaner and breather tube so you can see more of the beautiful 103 engine. I'm liking this bike more every day.

20200729_232125.jpg
 

·
weird member
Joined
·
2,260 Posts
Maiden voyage with the oil cooler, so far, no leaks. However, my rear brake reservoir was leaking at the cap pretty bad. Was pretty sure I had screwed the lid down all the way.

Totally didn't bring any tools but a screwdriver, I need to get a dedicated set of allens to stay on the bike (I have a multi-tool, screw driver, adjustable wrench... everything but a set of allens). Luckily, a guy at the coffee place had a set in his car, got it tightened down now and cleaned up.

I worry about the brake reservoir being located where it is though because it's plastic and just waiting for a rock to get kicked up and crack it.

Anyway, I think the cooler is working right, the oil tank at least seemed to warm up slower than the engine (oil flow goes engine > filter > cooler > tank) and less than it normally does, and engine seemed to be a good maybe 10° cooler than normal by the time I got where I normally stop.

Other than that, someone almost came over on top of me on the 6 lane. No Turn signal, I was in the left lane, they were in the middle, they decided to come to the left lane because... who knows because they didn't end up passing whoever they were behind (actually, they were going slower than surrounding traffic, and at least 2 miles down the road, never turned left anywhere)? I honked and rev bombed and they froze half way over in my lane so I just punched it and got ahead.

Dealt with another dickhead a few days ago too, some Florida driver (I know cause I passed them) tried to race ahead of me. Leaving my house the way I go, there's a 4 lane highway and the right lane ends and it becomes a 2 lane for a bit. Well, I was in the left doing maybe 35-37 in a 30. As we are nearing the right lane ending, there was nobody ahead of the guy in the right lane and nobody to his left in the left lane and I was 1.5-2 car lengths ahead and I see him speed up, so I sped up, so then he sped up even more (guess he wanted to be first in line when the lanes merged), so I punched it because, had I even never sped up at all, there's no way he would have gotten ahead without coming dangerously close to hitting me, was going about 55 mph by the time the lanes merged but when I womped it, I guess he decided he couldn't race me and got behind me. I slowed back down to 35 mph, but that situation makes me glad I had all this engine work done. Wtf is wrong with people?
 

·
American
Joined
·
26,752 Posts
I have the small bolt covers on. Some of the other ones don't fit well so they might not even go on. here is a pic of the right side. I like the look with the smaller air cleaner and breather tube so you can see more of the beautiful 103 engine. I'm liking this bike more every day.

View attachment 786721
I like the caps too...

786729
 

·
Registered
Joined
·
1,100 Posts
I have the small bolt covers on. Some of the other ones don't fit well so they might not even go on. here is a pic of the right side. I like the look with the smaller air cleaner and breather tube so you can see more of the beautiful 103 engine. I'm liking this bike more every day.

View attachment 786721
That's Crazy Purdy, post up a full pic of that bike! Please!
I'm curious about the seat? That can't be stock?
 

·
Registered
Joined
·
2,376 Posts
Installed highway pegs on my sweetie's Freewheeler today. H-D Chrome and Rubber foot pegs on Ciro frame mounts.



 

·
Registered
Joined
·
35 Posts
786736
786737

So long story short, I had a chlorine spill in the garage that I didn't find for a couple of years. It screwed up the chrome pretty bad. After 5 weeks of cleaning and replacing the bad chrome. Buffing the paint, and installing a batwing, I don't think it turned out too bad. Wish I would have taken before pics.
 

·
Noel
Joined
·
8,505 Posts
Playing with the Destroyer, I think I have found an issue with the Screaming Eagle Super Tuner Pro, apparently the VCI (vehicle communication interface) orange box won't talk to my laptop, at first I though maybe it was caused by my upgrade to windows 10, I last used it in 2016 after the engine rebuild when my laptop was using windows 7.

So I proceeded to uninstall and reinstall older and latest versions of Super Tuner, none of them would establish a comm channel via the USB connection.

I also have a TTS Master Tune blue VCI box and software, but I needed to reinstall the software on the WIN-10 laptop, after getting that done with all current releases, I was able to establish communications between the race bike and laptop. Whewwwwww!!!

I pulled a copy of the last saved TTS tune which sits on a EPROM in the blue box, then pulled that last Delphi Super Tuner map off of the bikes ECM as a back up if I desire to go back to it.

Now I can continue testing of the bikes basic performance.

Over the years I kept the orange Super tuner connected to the bike to use the data gathering features, now I suspect the Super Tuner hardware STB and might be the cause of rough run conditions and intermittent stalling I have experienced in recent testing.

Planning another round of mid day street testing to see how well she runs while leave all external accessories removed, If that proves out I will be highly relieved that I don't have more serious issues with the engine, though it's possible the old fuel might have gummed up the injectors, they might also need a cleaning, we'll see how all this turns out soon.
 

·
Registered
Joined
·
13 Posts
I like this thread and looking at the things others are doing. I took a break from my bike project for a few. It is not back on the road yet. The next thing I need to do is get the custom length throttle cable made. I need to take it back off and cut the cable sheath an inch shorter. Hope fully I get the motivation to work on the bike soon. I think the state of affairs in this country has given me depression. I know a bike ride will do me some good!!!!
 
4981 - 5000 of 5173 Posts
Top